502 Street Scene Forums banner
1 - 5 of 5 Posts

·
Welcome to The War Room
Joined
·
2,518 Posts
Discussion Starter · #1 ·
Ok, question, is it notorious in RX7's for the oil gauge to not show oil pressure until you rev? Like my oil pressure gauge stays on the lowest until I hold down the throttle at 3k for a few seconds, then the pressure will go up. Is that normal, or should I check something out? Car runs fine, just one of a few weird things my car does.

Oh, and while I'm asking, do you seriously have to lower one side of the engine to change the water pump on a 94 626? I'm seriously needing to get this car running, and i dont have the money to take to a shop. But thanks in advanced.
 

·
The Rotary Masochist
Joined
·
2,741 Posts
It is pretty common for the pressure sender to crap out. It's also common for the front cover o-ring to crap out causing the symptoms you're seeing. Best thing to do is hook up a good mechanical gauge to check the pressure and see what you have. If the pressure checks out then start with replacing the sender to fix the issue. If it doesn't check out the front cover needs to come off.

No idea on the 626.
 

·
Dances on the Redline.
Joined
·
2,945 Posts
If memory serves me correct then you do have to lower the engine off of 1 or 2 mounts to get to the water pump housing. It's not that bad in all honesty.
 

·
Banned
Joined
·
8,942 Posts
Check it with a mechanical gauge, but youll need an adapter to plug an npt fitting in there.

Or if you think its the sender, well, I have a few.
 

·
OH BOY!!!!
Joined
·
4,678 Posts
monkey I need a oil sending unit. Mine shoots up over the top of the gauge when i turn the car on.
 
1 - 5 of 5 Posts
Top